Page 1 of 1

Flatpak/Deb installs = all torrents stalled - resolved!

Posted: Sat May 06, 2023 1:19 am
by Yodaminium
Hi everyone,

inxi -v2
Host: pappa Kernel: 6.2.0-20-generic arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.4 Distro: Ubuntu 23.04 (Lunar Lobster)
Type: Desktop System: ASRock product: Z790 PG Lightning v: N/A
Mobo: ASRock model: Z790 PG Lightning serial: <superuser required>
UEFI: American Megatrends LLC. v: 5.01 date: 01/09/2023
Info: 24-core (8-mt/16-st) 13th Gen Intel Core i9-13900K [MST AMCP]
speed (MHz): avg: 3000 min/max: 800/5500:5800:4300
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] driver: nvidia v: 515.105.01
Display: x11 server: X.Org v: with: Xwayland v: 22.1.8 driver: X:
loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa
gpu: nvidia,nvidia-nvswitch resolution: 1: 2560x1440 2: 2560x1440
3: 2560x1440~144Hz
API: OpenGL v: 4.6.0 NVIDIA 515.105.01 renderer: NVIDIA GeForce RTX 3070
Device-1: Realtek RTL8125 2.5GbE driver: r8169
Local Storage: total: 19.33 TiB used: 6.07 TiB (31.4%)
Processes: 442 Uptime: 2h 14m Memory: 31.09 GiB used: 5.55 GiB (17.8%)
Shell: Bash inxi: 3.3.25
Winblows 22H2 19045.2364

My first time placing a post on this forum; if I am in the wrong thread please move this for me?

I have been using QBitTorrent for a LONG time on both Windows and Linux. First time I ever had a need to ask questions :-)
Good software.

The issue(s) I have is that every time I add a torrent to the app it immediately goes into a stalled state.

I was using Qbittorrent 4.5.2(? - may have been .1 but I believe I updated to .2 when that security release came out).

I was running Kubuntu 22.10 and everything was working fine when out of the blue I started to have REALLY slow download speeds but only for torrenting (or at last that's what I believed at the time). I checked the trackers list for each torrent and there were a bunch (about half of them) that were no reachable so I delete them - maybe that was an oops moment? I am unsure because like I said, never had any issues with Qbittorrent before.

About the same time this was happening I got offered an upgrade to Kubuntu 23.04 as my 22.10 was at end of life. I took it and the upgrade seemed to go just fine - I never suspected it might be part of the issue.

AS a troubleshooting step for my qbittorrent problem I uninstalled it (apt install/uninstall), deleted all the left over qbittorrent stuff in my home directly and then attempted to reinstall and was presented with the security warning about the ppa being disabled as no control file available for my version of Linux. SO, I downloaded the deb form the qbittorrent site and sued it and ended up with the same stalled torrents. I tried a Kubuntu torrent download and it stalled immediately. A quick reboot to my Windows partition revealed all is well with torrenting using Windows->Qbittorrent.

Back in Linux I downloaded the flat pack app-image from qbittorrent website and using it the torrents were STILL stalled immediately upon adding them to the app - this step led me to believe this is a Linux version thing and not a qbittorrent thing but I am not sure so asking here.

Has anyone gotten Qbittorrent 4.5.2 working on Ubuntu 23.04 in any of it's flavors?

Does anyone know how I can fix this?
Booting into Windows makes me sick to my stomach I hate it that much and Transmission, Deluge, Utorrent, even Ktorrent does not come close to the functionally and options of qbittorrent and I want it back.

Thank you to all!

Re: Flatpak/Deb installs = all torrents stalled

Posted: Tue May 09, 2023 10:14 pm
by Yodaminium
18 views and not one reply.
Is this issue that hard to resolve?

I just posted to say I am using K-Torrent and it seems to have all the functionality of qbittorrent, I noticed once I took a REAL good look at the settings.
The GUI is a bit different but very user friendly.
It also has the ability to assign a specific network adapter the the application which is exactly what I was missing from deluge, transmission etc.

Hopefully, the devs will create a qbittorrent package for Ubuntu 23.04 also I can switch back to my favorite torrenting app but for now I am good.

Re: Flatpak/Deb installs = all torrents stalled - resolved, kinda

Posted: Sat May 13, 2023 10:53 am
by Peter
KTorrent is nice but it's not as widely accepted on trackers, and it is not cross-platform.

I checked the flatpak and it looks like a permission issue. If you run with sudo (please don't), it has network access. Check the Github Issues page if anyone reported it, or if there is any progress. I mean, I looked up Flatpak documentation and it is really, really lacking. There is nothing on network access, issues, etc. I tried using "setcap", I looked everywhere, there is nothing. So my attempt at "fixing it" went nowhere.

I just compile the latest version on 23.04 by hand, takes like 2 minutes.

Re: Flatpak/Deb installs = all torrents stalled - resolved, kinda

Posted: Sat May 20, 2023 1:10 am
by Yodaminium
Hi Peter - thank you for your input I appreciate it. So far, no issues whatsoever with KTorrent and it is just as good if not better than Qbittorrent.

I also spoke to soon when I said Qbittorrent was working OK on Windows - it is not, exactly the same thing is happening on Windows as is on Linux. No matter what torrent I add it goes immediate into the stalled state and will not download anything, from any torrent.

In Windows I am a 3rd level technical support technician and there isn't much I have faced in my 30'ish years that I have not been able to resolve. That being said I did my best and could not get QBittorrent to download anything - after 8 full hours of troubleshooting, including installing it on my personal laptop -which has not ever had QBittorrent installed on it before. So no leftovers to mess up my trouble shooting. I had the same issue. I thought this is the application not my PC's...

I drove to my brother-in-laws place and tried it there on my personal laptop and same issue.

This torrent stalled immediately upon starting the download attempt: ... so.torrent

I tried a few other torrents and all the same.

Back at home I loaded up Linux again and started the same torrent using KTorrent and it was downloaded shorty thereafter.

SO, I have discovered this issue is not my PC's
this is issue is not my firewall/router or switch.

I am not a programmer so I have no clue what it is the application is doing wrong as there is no trace of errors - just the stalled state on all PC's/networks I tried it on.

The only thing of note outside of everything I have already said is that a few days (maybe a week or so?)before this started I was prompted with a popup window in QTorrent when one of my torrents finished download that said, "Congratulations on you 1000th torrent download, then it went on to advertise itself as an application freely available for all that survived on donations and if I cannot afford a donation to please leave a good review on whatever that review site was). I closed it almost immediately and thought to myself, sure I can fire off $100 bucks or so. Then promptly forgot all about it until about the middle of the time it took me to do all my trouble shooting - approx 8-10 hours over a few days.

SO, I thought to myself, what can be done. to the rescue. I downloaded QTorrent version 4.1.2 and fired it up and very shortly thereafter Linux Mint was downloaded via torrent once more!

SO this begs the question, why did the latest version quit downloading torrents a short period after I was prompted to donate or leave a good review at blah?

(I will still be donating that $100 bucks -- probably yearly now that I think about it as, I have used and loved QBittorrent since shortly after it's first release)

I thought that Qbit developers would surely like to know about this, even it is just to think to themselves,"Huh? I wonder what caused that crazy shit?"

Me? I am perfectly OK with using the old version - I boot into Winblows about every 2-3 months so who cares, and on Linux K Torrent is working beautifully!

Cheers all - maybe I should try to turn all the above into a novel? Maybe a torrent thriller? Dam...

Re: Flatpak/Deb installs = all torrents stalled - resolved!

Posted: Sat May 20, 2023 10:15 am
by Peter
Yeah I am not saying it's not important, Flatpak is basically broken as it is now.
I reported it on the bug tracker, we'll see.